website was down a few days

25 posts / 0 new
Last post
Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Jul 24 2021 17:41
website was down a few days

I noticed that libcom.org was down for a few days and it had me worried. I hope everything's ok!

Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Jul 24 2021 17:44

Hmm, just checking the forum and seeing there were posts made in the days the website was down. So that's weird. Was it down for some people but not others?

Noah Fence's picture
Noah Fence
Offline
Joined: 18-12-12
Jul 24 2021 17:50

It was down for me too. What day/s did you notice it?

Fozzie's picture
Fozzie
Offline
Joined: 4-12-03
Jul 24 2021 18:01

I had an issue connecting for a few days using my usual bookmarks and cached links.

But I googled Libcom and got in that way.

Seems fine now.

A bit odd.

Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Jul 24 2021 18:16

I forget when I first noticed it but I think from about the middle of the week until yesterday.

R Totale's picture
R Totale
Offline
Joined: 15-02-18
Jul 24 2021 18:41

Yeah, was down for me too.

radicalgraffiti
Online
Joined: 4-11-07
Jul 25 2021 01:50

it worked for me, but some people said it didn't work via http (an unencrypted connection)

Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Jul 25 2021 17:29
radicalgraffiti wrote:
it worked for me, but some people said it didn't work via http (an unencrypted connection)

That might have been it! Weird, I thought my internet automatically went to https when I go to a website but I just checked and somehow that wasn't happening for libcom sad

I better remember to pay attention to that in the future, don't want to be using http when logging in

Red Marriott's picture
Red Marriott
Offline
Joined: 7-05-06
Jul 26 2021 00:38

I could log in on Firefox but not Chrome.

ajjohnstone
Offline
Joined: 20-04-08
Jul 26 2021 03:37

Our blogs had similar issues recently and I don't know if it applies but it's down to that some
browsers warning the user whenever they visit a website via HTTP instead of HTTPS.

I had to configure the blog to redirect HTTP traffic to HTTPS. This was a simple matter on Blogger in changing the settings for the blog. Don't know for yourselves.

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Jul 26 2021 14:51

hmm it was okay for us. Sorry about that. The main thing is to always make sure you visit the secure HTTPS version of the site: https://libcom.org
and if you ever want to check if the site is down for everyone or just you, you can go to: https://downforeveryoneorjustme.com/

darren p's picture
darren p
Offline
Joined: 5-07-06
Jul 26 2021 16:31

I think, as has been said before, the server was rejecting connections via unsecure HTTP but accepting them via secure HTTP.

I also thought my browser automatically connected to HTTPS but that was not the case, so I installed this browser extension from the Electronic Frontier Foundation. May be useful for others too.

https://www.eff.org/https-everywhere

Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Jul 28 2021 00:03

Just installed it. Thanks, Darren. I notice "Encrypt All Sites Eligible" is off by default. Would you recommend turning it on or no?

Mike Harman
Offline
Joined: 7-02-06
Jul 29 2021 08:44

Yes http was down, but https was up - and it took a while for us to notice sorry (probably because most people are using https these days, but google hasn't always caught up).

R Totale's picture
R Totale
Offline
Joined: 15-02-18
Jul 29 2021 08:48

On the http/s stuff, how does it work with phones? Idk about anyone else, but I tend to assume that phone browsers are less likely to be customised, I have various adblocks and other plugs for my laptop browser but just running the basic on my mobile. Am I right in thinking that the majority of phone traffic would probably be http rather than s?

Mike Harman
Offline
Joined: 7-02-06
Jul 29 2021 08:53

I think it depends where the phone traffic comes from, whether someone follows an https link or not.

New version of the site (extremely slow progress, but actively being worked on and pace is picking up finally) will be all-https and on different hosting entirely, so this problem will go away although I'm sure we'll find some new ones.

darren p's picture
darren p
Offline
Joined: 5-07-06
Jul 29 2021 09:47
Lucky Black Cat wrote:
I notice "Encrypt All Sites Eligible" is off by default. Would you recommend turning it on or no?

What I found out through Reddit: "If you don't check, you can visit both HTTP and HTTPS sites. If you check, you can only visit HTTPS sites"

radicalgraffiti
Online
Joined: 4-11-07
Jul 30 2021 00:41
darren p wrote:
Lucky Black Cat wrote:
I notice "Encrypt All Sites Eligible" is off by default. Would you recommend turning it on or no?

What I found out through Reddit: "If you don't check, you can visit both HTTP and HTTPS sites. If you check, you can only visit HTTPS sites"

what actually happens is if you try to visit a site and it cant find a https version it warns you and asks you if you really want carry on

Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Jul 31 2021 21:23

I installed it but it isn't working for me, even with the "Encrypt All Sites Eligible" checked. Oh well. Thanks anyways.

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Aug 2 2021 17:05

Sorry do you mean that libcom still isn't working? Or wasn't again for a time?

Sike's picture
Sike
Offline
Joined: 25-10-15
Aug 3 2021 12:34

When you start your browser and attempt to access Libcom are you coming from a saved bookmark? Is this bookmark older? Possibly from before Libcom was using https encryption? If so, then you might want to check and see if the bookmark that you are using to attempt to access the site is not written using an unencrypted referer header http as opposed to https, and if the bookmark is saved as an http rather than an https link then you might be able to solve the problem by editing the bookmark and retyping and saving it as https://libcom.org

Lucky Black Cat's picture
Lucky Black Cat
Offline
Joined: 11-02-18
Aug 3 2021 18:04
Steven. wrote:
Sorry do you mean that libcom still isn't working? Or wasn't again for a time?

I meant the browser extension HTTPS Everywhere. (Though now the extension is working for me.)

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Aug 3 2021 19:19

Okay thanks for clarifying!

R Totale's picture
R Totale
Offline
Joined: 15-02-18
Aug 6 2021 20:53

Now if I try to access via https, I'm currently getting a message saying "Bitdefender has blocked this page. Your connection to this website is not safe due to expired certificate and was blocked. Attackers might try to steal sensitive information from you, such as passwords or credit cards." Which doesn't come up using the non-https route.

Steven.'s picture
Steven.
Offline
Joined: 27-06-06
Aug 6 2021 22:54

We did have a problem with the secure site briefly, but hopefully that should now be fixed